I'm getting weired problem, after adding my virtual host conf entry localhost isn't working (getting forbiden 403) but 127...1 does (all utilized via browser - http), here you've my conf:

NameVirtualHost *:80
<VirtualHost *:80>
DocumentRoot "/MyData/__www/default"
ServerName localhost
<Location />
        Order deny,allow
        Deny from All   
        Allow from 127.0.0.1
        Options +FollowSymLinks -Indexes            
</Location>
</VirtualHost>

The funny factor is the fact that after i change allow from to:

 Allow from localhost

localhost works but 127...1 not, localhost is planned correctly in hosts file.

help,

cheers, /Marcin

On some systems, localhost maps for an IPv6 address, ::1. Try:

Allow from 127.0.0.1,::1