I'm attempting to setup a Django project like described on AlwaysData (http://wiki.alwaysdata.com/wiki/Implementing_a_Django_Application), but by myself computer.

I am using ArchLinux.

I acquired an access refused during my error_log after i visited your directory that contains the FastCGI script (exactly the same django.fcgi as with the hyperlink above) :

client denied by server configuration: /var/www/home

However, I'm able to access the project basically visit directory/django.fcgi rather than only directory/.

My .htaccess is :

AddHandler fastcgi-script .fcgi
Options +ExecCGI
DirectoryIndex django.fcgi
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ django.fcgi/$1 [QSA,L]

Basically comment the final line, I doesn't get the acces refused error and that i can use of my django project by both method (directory/ and directory/django.fcgi).

Nonetheless, I want the final type of this .htaccess to obtain clean Web addresses.

Are you aware what's the condition in my configuration?

Thanks ahead of time for the help.