I finished my initial C# project in Versus 2008 which is working now. However I have to publish this project onto my new website. This project is really a web application that interacts with my SQL Server 2008 Adventureworks database about this same computer(XP Professional OS). I'm running IIS 6. Manager, but I'm a newbie to both IIS 6. and Versus 2008.

I started by right-clicking the applying in Versus and choosing "Publish", but I have just selected File System, cause selecting Local IIS forces me to go in Password.

The issue is which i can't open this site from IIS without them compelling me for password. I've modified machine.config file several occasions within the processModel section, by setting username="D610-MASPNET", password="AutoGenerate". But this will make me enter built-in password after i attempt to notice. And I'm not sure what built-in ASPNET password is. After I cancel this password popup, it returns:

HTTP 401.one inchYou aren't approved to view this site.Inch

And I have totally reset the ASPNET password several occasions. First I attempted setting it to some password I understood, i quickly went the aspnet_regiis command to reinitialize it. I additionally attempted replacing other passwords, but not one of them have labored. I even attempted entering "SYSTEM" for username and AutoGenerate password, but even this prompts me to go in password. I've added the ASPNET user Read/Write/List permissions to any or all relevant folders. And That I attempted to produce a new website pointing to http://localhost/[AppName], but this forces me to go in password. So no making your way around that password.

I've modified Qualities for Default Website in IIS: Home Directory pointing to my application in Versus 2008 folder and Application Protection = Low. On Directory Security tab, I set username to D610-MIUSR_D610-M and that i checked "Enable anonymous access." I unchecked the Allow IIS to manage password.

And That I read a lot of MS URL's along with other websites to ascertain if I possibly could answer these complaints myself, but none of them of the helps labored either. This ought to be simple. I am just attempting to add my web application to my website. I understand that my website works cause I installed a default website with fundamental HTML and delay pills work.

What else can one try to be able to add this web application to my website?

I don't know if this sounds like it, but.... I've come across this error myself which is usually triggered by not getting the ASP.Internet version set to two. inside your Website qualities underneath the ASP.Internet tab. This setting is frequently past due to ASP.Internet 1.1 which may cause this error to happen. Note, that despite the fact that you're using Visual Studio 2008 the ASP.Internet Version continues to be must be 2. in IIS. I'd make sure this setting.

One important limitation to consider is you are just permitted one website on IIS6 on XP.

For those who have edited your machine.config you've introduced a lot of new variables in to the equation to correctly trobleshoot and fix the issue (not too editing machine.config by itself is dangerous, but it is a sign that there are a little of shotgun method of the issue).

You have to begin by wiping your slate neat and ensuring you possess an otherwise working system. Browsing an HTML page doesn't prove almost as much ast running HTML and running ASP.Internet are just like apples and bicycles.

The very best which i are conscious of for carrying this out is removing and re-installing IIS and whatever .Internet framework you are well on. If you're on 3.5 you want to do this for two and three point five. If you're able to you have to put machine.config and each version of web.config (except the main one inside your web application itself) to their defaults. There's nothing there you need to have to edit run an regular ASP.Internet application.

When you think you've got a tabla rasa and may browse an html page, then change its extension to .aspx and try to still browse it.

My last suggestion for today is:

Like a poster above stated set your ACLs around the folder where your site is (typically c:inetpubwwwroot) to ensure that the audience "Everybody" has "Full Access". Don't let it rest by doing this, even by yourself machine, however it takes file permissions from the equation. If you're still getting problems tell me, but essentially you have to begin with a "known good" condition should you ever aspire to understand this problem resolved.