I have got a XAMPP installation running on Home windows 7.

The moment I give a VirtualHost to httpd-vhosts.conf, Both 'regular' http://localhost And also the new dropbox.local arn't working.

This is exactly what I put into my httpd-vhosts.conf:

<VirtualHost *:80>
    ServerAdmin postmaster@dummy-host.localhost
    DocumentRoot "E:/Documenten/Dropbox/Dropbox/dummy-htdocs"
    ServerName dropbox.local
    ServerAlias www.dropbox.local
    ErrorLog "logs/dropbox.local-error.log"
    CustomLog "logs/dropbox.local-access.log" combined
</VirtualHost>

And So I researched my dropbox.local-error.log for just about any information:

[Thu Feb 02 10:41:57 2012] [error] [client 127.0.0.1] client denied by server configuration: E:/Documenten/Dropbox/Dropbox/dummy-htdocs/

This error appears to become solved with the addition of

<directory "E:/Documenten/Dropbox/Dropbox/dummy-htdocs">
     Allow from all
</directory>

However I recieve this error in dropbox.local-error.log:

[Thu Feb 02 10:45:56 2012] [error] [client ::1] Directory index forbidden by Options directive: E:/Documenten/Dropbox/Dropbox/dummy-htdocs/

In addition after i attempt to access http://localhost, I dont have any error within the regular error.log, although I recieve the error 403 after i attempt to can get on.

Can anybody help... It's driving me mad :S

EDIT: Also in httpd.conf there's the next (I have seen it pointed out multiple occasions, so before anybody states it):

<IfModule dir_module>
    DirectoryIndex index.php index.pl index.cgi index.asp index.shtml index.html index.htm \
                   default.php default.pl default.cgi default.asp default.shtml default.html default.htm \
                   home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>

Okay: This is exactly what Used to do now and it is solved:

My httpd-vhosts.conf appears like this now:

<VirtualHost dropbox.local:80>
    DocumentRoot "E:/Documenten/Dropbox/Dropbox/dummy-htdocs"
    ServerName dropbox.local
    ErrorLog "logs/dropbox.local-error.log"
    CustomLog "logs/dropbox.local-access.log" combined
    <Directory "E:/Documenten/Dropbox/Dropbox/dummy-htdocs">
        AllowOverride AuthConfig Indexes
        Order Allow,Deny
        Allow from all
    </Directory>
</VirtualHost>

First, I saw it's essential to have set the <Directory xx:xx> options. And So I place the <Directory > [..] </Directory>-part Within the <VirtualHost > [..] </VirtualHost>. Next, I added AllowOverride AuthConfig Indexes towards the <Directory> options.

Now http://localhost also indicates the dropbox-virtualhost. And So I added dropbox.local to <VirtualHost *:80> which causes it to be as `

FINALLY it really works :D!

I am a happy guy! :) :)

I really hope another person may use these details.