I'm attempting to render content produced with a php file in [jQuery Colorbox][1] through AJAX during my WordPress site. The PHP resides on a single server within the same domain. It really works perfect after i run it on localhost but it is not focusing on the server.

This is actually the connect to my website - http://shabdcreatives.com/portfolio

The hyperlinks are not invalid, for instance the next link works fine by itself:

http://shabdcreatives.com/wp-content/plugins/catgrid/includes/CatGridPost.php?ID=33

I simply will not open within the colorbox.

Even the php file I'm attempting to load is simply a fragment and doesn't CONTAIN any <html> or <body> tags.

I attempted the colorbox support group but no replies from their store yet

This is actually the code within the CatGridPost.php file that i'm bringing in the colorbox.. i attempted calling an ordinary text file too... it came back no error.. however the colorbox didn't show its contents either

require_once("../../../../wp-blog-header.php");
$thepost = get_post($_GET["ID"]);
$thecontent = $thepost->post_content;
$thetitle = $thepost->post_title;
$thelink = get_permalink($_GET["ID"]);
?>
<div id="cg-post-container">
<div id="cg-post-title">
    <a href="<?php echo $thelink; ?>"><?php echo $thetitle; ?></a>
</div>
<div id="cg-post-content">  
        <?php echo $thecontent; ?>
</div>          

Hi it's really a server problem with mod_security , i'd an identical problem and among my clients server i disabled the mod_security also it solved the problem.

But i wasn't getting an 404 error.

this is actually the link for reference http://drupal.org/node/370651

Likewise try altering the file permission : /wordpress-content/plug ins/catgrid/includes/CatGridPost.php

If it's a Wordpress whydont you attempt the built-in Ajax purpose of wordpress

http://codex.wordpress.org/AJAX_in_Plugins

For whatever reason your server is reacting having a 404 not found, then coming back the document.

Using the AJAX request it fails because clearly the customer thinks the request went badly.

Whenever you load the page the browser just shows that which you send into it since it thinks this content you are exhibiting is simply a 404 page. (A Custom 404 page)

I can not assist you to fix this issue since i have can't tell what's happening around the server side.

Possibly Control+F for 404 within the folder?

You are able to confirm this as the problem by clicking a couple of images then likely to Inspect Aspect in Google Chrome, then enabling the console. After that you can observe it states the GET unsuccessful with 404

Image showing the server is returning a 404