During my test enviroment I produced a Login and used the ASP.Internet Configuration in Visual Studio. It labored perfectly. However after testing I imported a current database to my sql-server which database includes existing asp.internet login tables(same structure). During my web-application I wish to begin using these imported tables rather than individuals during my testing database. I already checked the net.config along with the aspnetreg tool (have no idea the precise title :p)

My question: How do i alter the database utilized by my ASP.Internet login?

you need to overwrite the default application services connection string to be make use of your existing used DB

within the web.config connection string section alter the default connection string

        <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient"/>

to become whatever your connection string is

or if you wish to make use of a different connection string you are able to alter the title from the connection string utilized in the membership provider configurations also in web.config

<membership>
        <providers>
            <clear/>
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression="" applicationName="/"/>
        </providers>
    </membership>

Alter the title from the connectionStringName to another thing

EDIT Role provider code

<roleManager enabled="true">
        <providers>
            <clear/>
            <add connectionStringName="ApplicationServices" applicationName="/" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
        </providers>
    </roleManager>

Again you will need to change connectionStringName for your connection string.