I'm by using this guide: http://codingthis.com/platforms/linux/how-to-host-simple-content-with-amazon . com-elastic-cloud-computing-ec2/

I've got a folder named public_html during my /home/ec2-user directory having a test.html file.

Things I did to date:

sudo yummy -y install httpd php

sudo chkconfig httpd on

chmod 755 /home/ec2-user  (I've No Clue WHAT This May)

sudo nano /etc/httpd/conf/httpd.conf

  (transformed DocumentRoot to DocumentRoot /home/ec2-user/public_html)

TLDR: How do you allow it to be load my content (my html file) rather than the apache test page

EXTRA:

I've got a security group enabled for my instance with rules:

ICMP Allow ALL

TCP Allow ALL

UDP Allow ALL

TCP port 80 (Http)

is not your document root public_html rather than world wide web? why did u put ur pages under world wide web directory?

For those who have no content within the DocumentRoot that you simply set up then your default Apache install will highlight that page rather than yours. Also, look into the DirectoryIndex configuration to make certain when you are using index.php or default.html or something like that else this is set up too. It defaults to index.html