During my android project i'm writing a course for connecting to a server and here are the libraries that i have to use. However i have an error saying the next can't be resolved. How you can resolve this error? i'm using eclipse JAVA EE on home windows...

 import org.apache.http.entity.mime.MultipartEntity;
 import org.apache.http.entity.mime.content.ContentBody;
 import org.apache.http.entity.mime.content.FileBody;
 import org.apache.http.entity.mime.content.StringBody;

Download the jars in the apache commons site and add these to project and path.

attempt to download it from HttpClient Downloads

download the jar came from here : http://commons.apache.org/

do the installation inside your project such as this:

Right click any project and visit qualities. Around the left tab visit "java build path". And for the reason that on right visit libraries. Click add exterior jars and provide the road from the jar as well as your library is added.