I've installed passenger on my small Ubuntu 10.x server and i'm running Apache2. I've adopted the instruction "I believeInch pretty much. After establishing my virtual host and seeking to restart I get a unsuccessful to begin apache error because Documentroot takes one argument. I've the document root set is the one thing and so i am wondering if everyone could offer a few recommendations in regards to what I might be doing wrong.

I've my virtual hosts in separate files by domain title, therefore the directory structure around the server is one thing such as this

/etc/apache2/sites-available/dev.mydomain.com /etc/apache2/sites-enabled/dev.mydomain.com

both files possess the following inside them but restarting apache only fails after i place the vhost info within the enabled file.

<VirtualHost *:80>
  ServerName dev.mydomain.com
  DocumentRoot /home/myfolder/dev/vb/public    # <-- be sure to point to 'public'!
  <Directory /home/myfolder/dev/vb/public>
     AllowOverride all              # <-- relax Apache security settings
     Options -MultiViews            # <-- MultiViews must be turned off
  </Directory>
</VirtualHost>

Thank you for any assist you to can provide.

Comments in httpd.conf must go by themselves line.

perhaps you have given before determining VirtualHost

NameVirtualHost *:80

if the given remove individuals said line after document root and check out