localhost not work and IIS server stop apache error log seem like this

[Thu Jan 05 14:55:20 2012] [notice] Apache/2.2.21 (Win32) PHP/5.3.8 configured -- resuming normal operations
[Thu Jan 05 14:55:20 2012] [notice] Server built: Sep 10 2011 11:34:11
[Thu Jan 05 14:55:20 2012] [notice] Parent: Created child process 3152
[Thu Jan 05 14:55:20 2012] [notice] Child 3152: Child process is running
[Thu Jan 05 14:55:20 2012] [crit] (OS 10022)An invalid argument was supplied.  : Child 3152: setup_inherited_listeners(), WSASocket failed to open the inherited socket.
[Thu Jan 05 14:55:21 2012] [crit] Parent: child process exited with status 3 -- Aborting.
[Thu Jan 05 14:55:31 2012] [notice] Apache/2.2.21 (Win32) PHP/5.3.8 configured -- resuming normal operations
[Thu Jan 05 14:55:31 2012] [notice] Server built: Sep 10 2011 11:34:11
[Thu Jan 05 14:55:31 2012] [notice] Parent: Created child process 3988
[Thu Jan 05 14:55:31 2012] [notice] Child 3988: Child process is running
[Thu Jan 05 14:55:31 2012] [crit] (OS 10022)An invalid argument was supplied.  : Child 3988: setup_inherited_listeners(), WSASocket failed to open the inherited socket.
[Thu Jan 05 14:55:31 2012] [crit] Parent: child process exited with status 3 -- Aborting.

anybody know reason behind this plz help for me personally

It seems to become a common problem on Win XP SP2.

" The simple option would be to uncheck the “Enable LMHOSTS Lookup” box within the TCP/IP protocol setup (under WINS setting). Listed here are the steps to get this done:

Open “Control Panel” then “Network Connections.”
Right-click “Local Area Connection” and choose “Properties.”
Double-click the “Internet Protocol (TCP/IP)” line to spread out the “Properties.”
Around the “General” tab, click on the “Advanced” button.
Choose the “WINS” tab and uncheck the “Enable LMHOSTS Lookup” box.”
"

http://www.jennyconnors.com/computers/installing-apache2-and-the-wsasocket-failed-to-open-the-inherited-socket-error