Following this guide on CentOS 5.2, just getting nagios setup the very first time. The primary page turns up all right, however when I attempt to see the pages that needs to be produced with a cgi process, opera prompts me in order to save the .cgi rather, so apache's clearly lacking the knowledge of that it must run the cgi and obtain back some html from this.

The odd factor is, though, that, so far as I will tell, apache should be running these files as cgi. nagios.conf:


# SAMPLE CONFIG SNIPPETS FOR APACHE WEB SERVER
# Last Modified: 11-26-2005
#
# This file contains examples of entries that need
# to be incorporated into your Apache web server
# configuration file.  Customize the paths, etc. as
# needed to fit your system.

ScriptAlias /nagios/cgi-bin/ "/usr/lib/nagios/cgi/"


#  SSLRequireSSL
   Options +ExecCGI
   AddHandler cgi-script .cgi
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /etc/nagios/htpasswd.users
   Require valid-user


Alias /nagios "/usr/share/nagios/"


#  SSLRequireSSL
   DirectoryIndex index.php
   Options None
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /etc/nagios/htpasswd.users
   Require valid-use

Either the ScriptAlias directive or ExecCGI option ought to be triggering this, but neither of these appears to work.

This config file is being parsed by apache, if I move it of conf.d, /nagios provides a 404.

The .cgi files truly are within the /nagios/cgi-bin/ directory, and so i did not specify the wrong directory.

Searching appeared to simply provide individuals who struggled with permissions, which isn't the problem here. This appears in my experience to become a pretty fundamental factor, but despite the superb apache documentation, I am at a little of the loss (used cherokee an excessive amount of recently :) ).

verify it's set as executable (i do think) which apache has permission to professional, AND, understands how to handle CGI's correctly.

also, are the alias's correct? can there be something at /usr/share/nagios, in addition to at /usr/lib/nagios/cgi/? (simply not the way i do things)