I've got a couple versions of python on my small box. My application uses python 2.7 which can be found in /usr/local/bin/python. Apache appears to become utilizing an earlier version in /usr/bin/python. How do i configure Apache to utilize a later version of Python for my application?

You cannot. Either rebuild mod_wsgi from the other version of Python, or alter the shebang line inside your CGI scripts towards the other executable.

I possibly could be mistaking, but whatever user apache is began with includes a profile which likely has got the search path inside it. You can alter the search road to search /usr/local/bin before /usr/bin, though this isn't a perfect approach. Whatever default spend is placed for that account utilized by Apache, just check you have an rc-file for your spend, and when not, create one.