I discovered an identical question here, but did not assist me to.

I essentially have apache setup on my small OS X. I additionally have Django installed.

However, after i attempt to load the page with the browser in your area, i recieve:

Forbidden

You don't have permission to access / on this server.

I've an authentic httpd.conf using the only modification of enabling vhosts in which i've:

<VirtualHost *:80>
     ServerAdmin webmaster@dummy-host.example.com
     DocumentRoot "/Dropbox/project/www/"
     ServerName touch.loc
  #   ServerAlias www.dummy-host.example.com
     ErrorLog "/Dropbox/project/www/log/error.log"
     CustomLog "/Dropbox/project/www/log/access.log" common
</VirtualHost>

And also the error.log file gives:

[Tue May 03 20:22:56 2011] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /Dropbox/project/www/

I just read around also it appears like i must add the next towards the httpd.conf:

<Directory /Dropbox/project/www >
Order deny,allow
Allow from all
</Directory>

By which situation i recieve:

[Tue May 03 20:27:55 2011] [error] [client 127.0.0.1] client denied by server configuration: /Dropbox/project/www/

Can someone assist me to fix this annoyance? How do i further Investigate it? Is there related to customers/groups?

UPDATE: Then i added the choices +Indexes and also the permissions opened up. However, if i attempt to load the page, file structure seems rather than the wsgi file to pickup and load the web site. What will be the reason for your?

here's my .wsgi file:

 import os
import sys
sys.stdout = sys.stderr
# Add the virtual Python environment site-packages directory to the path
import site
site.addsitedir('/usr/lib/python2.6/dist-packages')
#If your project is not on your PYTHONPATH by default you can add the following
sys.path.append('/Dropbox/project/www/')
sys.path.append('/Dropbox/project/www/project')

# Avoid ``[Errno 13] Permission denied: '/var/www/.python-eggs'`` messages
os.environ['PYTHON_EGG_CACHE'] = '/Dropbox/project/www/mod_wsgi/egg-cache'
os.environ['DJANGO_SETTINGS_MODULE'] = 'project.settings'



import django.core.handlers.wsgi
application = django.core.handlers.wsgi.WSGIHandler()

You appear to become missing anything inside your Apache configuration that really serves the Django application. You have to browse the Django mod_wsgi documentation - the very first type of code there's what you are missing.

Observe that your code shouldn't live underneath the DocumentRoot.