I can not appear to create regex properly for that directive.

The syntax is:

<LocationMatch regex> ... </LocationMatch>

I have attempted most of the following with no success:

<LocationMatch "^/(admin-media|connect|css|downloads|images|images-web|js)/.+$">
<LocationMatch "^/(admin-media|connect|css|downloads|images|images-web|js)/.+">
<LocationMatch "/(admin-media|connect|css|downloads|images|images-web|js)/.+$">
<LocationMatch "/(admin-media|connect|css|downloads|images|images-web|js)/.">

Essentially, I am attempting to override my default handler to None for addresses that match http://mysite/css/anything, however with no luck!

I possibly could try establishing <Location "/admin">, and so on, but that is just bloatedness

Are you currently really certain your condition is by using the LocationMatch directive? All of your good examples appear perfectly valid in my experience. I suspect that you're woofing in the wrong tree here.

Are you certain the regex is really performed when placed in the string ("") or perhaps is it treated like a literal?

Are you currently setting this inside your .htaccess file or perhaps your global config file? The .htaccess file can't do LocationMatch

Have you got "RewriteEngine on" within your VirtualHost directive? (and mod_rewrite enabled)