Our current Apache installations are running Apache 2.. Now we want to include some Rails programs and intend to run them on Apache with Phusion Passenger. I have become conflicting reviews about whether we have to upgrade Apache to two.2 to be able to use Passenger (an advisor I highly respect suggested that somebody from Phusion states 2. ought to be fine.

Anybody running Passenger with Apache 2. being produced?

I had been of the opinion the minimum version for Apache with Passenger was 2.2, but when you mind to their website and appear within the Users Guide I am sure it'll say the thing you need.

i had been choose by doing this. (optional)

im havent using Pasenger when production, i recieve simple deploy rails now. only create rails application @ etc/rails_application/myapp/ and upload all application folder and public to myapp/application. i quickly simply need to unchecklist @ atmosphere for production and configurated at database.yml

i quickly replicated public @ http/public_html folder

run mongrel -> rewrite 12007 to 80 -> restart mongrel

if u get problem, ur application only apper in index, and obtain error when connect to another page.

only request to admin host to configur .httaccess

for instance like

RewriteEngine on
RewriteCond %{HTTP_HOST} ^myapp.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.myapp.com$
RewriteRule ^.*$ "http\:\/\/127\.0\.0\.1\:12007%{REQUEST_URI}" [P,QSA,L]

or do like railsninja stated :)

Since nobody appears to possess a definitive answer, I am likely to think that the solution I had been distributed by someone at Phusion is definitive. It's on the internet Groups at http://groups.google.com/group/phusion-passenger/browse_thread/thread/789f4f6e8f1c542d.

According to him that Apache 2. or more ought to be fine. (Because it exercised, we could opt for Apache 2.2 with this server, therefore the point was moot for all of us.)

You do not need 2.2. 2. works fine and when it does not it's considered a bug. Nevertheless 2.2 is most likely much better than 2. so no matter the minimum supported version you need to choose 2.2.