I understand this sounds odd, but trust me, it's what's happening. Listed here are my system configurations:

Windows7
Apache 2.2
PHP 5.2.12
Xdebug 2..5

I've XDebug set up during my PHP.ini file. After I run php -m, I actually do actually observe that Xdebug is loaded. Now, basically start Apache Like A SERVICE (or through the Apache Monitor), and run phpinfo(), it's not showing Xdebug to be loaded.

However, (now here's the crazy part), basically visit my Apache bin directory, and just run httpd.exe, after which go and check out phpinfo(), Xdebug now shows to be loaded!

Also, evaluating some phpinfo() when began via service or by command line, it appears such as the php.ini file is identical for either situation. Everything looks exactly the same aside from the Xdebug being loaded part.

Please, for those who have any ideas it might be greatly appreciated.

Generally there's different configuration files for every way possible of invoking a clear case of php: HTTP/CLI etc (a minimum of this could be on *nix)

I recommend carrying out a explore the body for php*ini and find out for those who have multiple files with varying/missing Xdebug configurations.

I'd an identical trouble with Xdebug in Home windows/IIS - php -m demonstrated the module as loaded, but phpinfo() didn't. Switched to be considered a permissions problem - after i set the xdebug .dll to provide read use of anonymous customers, it began working. I'd check permissions on that .dll to make certain that whatever user Apache is running as can access it.

I've got a similar problem with home windows 7, wampserver2 and xdebug. Thank you for explaining it or I never might have thought it was. Basically ever look for a fix I'll inform you. I attempted permissions Ryan but this didn't repair it.

php -i and php -m reveal that xdebug has loaded. phpinfo() doesn't. Unlike yourself I am unable to get xdebug to load by running httpd within the console. After I run httpd within the console I recieve exactly the same result as not running it within the console.

You will find no alerts within the logs. With regards to php I only obtain the below.

[Thu Jun 24 11:20:55 2010] [notice] Apache/2.2.11 (Win32) PHP/5.2. set up -- returning to normal procedures

It's possibly a buggy version/combination. I'd another problem (XDebug wasn't identifying some variables), the issue removed up after i when as much as 2.1..

http://xdebug.org/download.php