Hey Men, This continues to be requested a great deal in forums round the internet but after frantically trying to find the answer Im still unable to configure my Apache server to operate on port 80. After I alter the port in config to 85, Apache works but this involves maunally entering 85 within the address bar each time with localhost.

I've attempted to discover which program is applying port 80 however i cannot develop anything. When i first joined netstat -n -a -o -p TCP in cmd and that i emerged with this particular information Local Address ...:80 Condition: Listening PID: 4

I Quickly joined tasklist in cmd trying to puzzle out which services are by using this port. Appears like "System" is on PID 4. I've set up Skype not to use port 80 with no luck. I've Microsoft WebMatrix placed on Home windows 7 and that i even erased IIS 7.5 Server Express to free this port but routinely without success.

Can everyone please assist me? BTW i'm using Home windows 7. And i'm using XAMPP. Thanks

Skype blocks 80 for whatever reason, I'd a difficult time discovering that out. :)

I understand this really is a little old, but simply just in case someone results in it via google when i did:

Switched to be that "Web Deployment Agent Service" was taking port 80. The moment it had been disabled apache began right up. I have are available across a number of saying a few of the SQL Server services were obstructing it.

Cheers, Buzzology

I’m presently beta testing the following version of Home windows, Home windows 7 and discovered an unusual problem while looking to get Apache to set up and operated with the default port, 80.

Running the command ‘netstat -ano’ in the command line revealed that port 80 has been utilized by PID 4.

Searching for PID 4 using Energy Spend after which Task Manager revealed that PID 4 may be the NT Kernel!

So Home windows 7 automatically seems to become using port 80.

After a little of shopping around the web and doing a bit of research of my very own I discovered the service http.sys was the reason and all sorts of I desired to complete was disable it however i couldn't find this particular service indexed by the help user interface applet. So what’s the answer?

You need to disable the http.sys service by hand through the registry:

1) Launch RegEdit:

2) Visit: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesHTTP

3) Give a new DWORD (32-bit) value

4) Title it ‘NoRun’ excluding the quotes

5) Double click on the new property

6) Within the Value data area type ’1′ excluding quotes and click on OK

7) Re-boot your pc

You need to now discover that Apache will begin on port 80!

Okay... Gotcha. Web Deployment Agent service was triggering "System" with Port id= 4 to make use of Port 80. I disabled it in Services, transformed to Port 80 in Apache config and bingo, Apache began focusing on its default port. I Quickly uninstalled Microsoft Web Deploy 2. to permanently remove this issue.

Thnx all

Oh, thanks a 1000 occasions. I have been wrestling all day long with getting port 80 free. Attempted exactly what I located on the forums, forums, such as the regex edit above, but still there is:

netstat -ano -p tcp findstr LISTENING

TCP    0.0.0.0:80             0.0.0.0                  LISTENING       4
TCP    0.0.0.0:445            0.0.0.0                  LISTENING       4  etc.

Now port 80 has disappeared in the display. Exactly what a relief!