Yesterday, I'd a fistful of websites running in your area quickly and easily. Today, nothing opens and I've got a log filled with this:

Symbolic link not allowed or link target not accessible: /var/www

I've no clue things i did (I did not open/change my httpd.conf file by any means), but clearly it had been something bad. I run virtual hosts and also the root sites are situated in ~/Developer/www. To be able to share the config files across multiple Apple computers with various home sites, I have produced a symlink, /var/www which indicates ~/Developer/www.

All the virtualhost config files point their DocumentRoot to /var/www/project_directory and it is own root directory has got the FollowSymLinks option:

<VirtualHost *:80>
  ServerName   localhost
  ServerAlias  localhost.local localhost.dev
  DocumentRoot /var/www/_localhost

  <Directory /var/www/_localhost>
    Options FollowSymLinks Indexes
    AllowOverride None
    Order deny,allow
    Allow from all
  </Directory>
</VirtualHost>

My primary httpd.conf file, similarly, has got the FollowSymLinks option enabled for /:

<Directory />
  Options FollowSymLinks
  AllowOverride None
  Order deny,allow
  Deny from all
</Directory>

Any idea things i might have completed to stop Apache from understanding symlinks or, even better, things i can perform to have it back in line?

Thanks.

UPDATE:

I ought to include that all the sites within the "stack" are executable by all customers which this is actually the native Apache install on OS X Lion.

I suppose I made a belief which i should not have. I'd verified every relevant permission except the one which obviously mattered. Apache did not have execute permissions on my small top level home directory. I checked, re-checked and triple checked everything under that, but getting never transformed anything for the reason that directory itself, I simply did not anticipate it being the problem.