Apache on ubuntu 11.04 is exhibiting /tag/ while using /tag.php file. I suspect that this is the most well-liked behavior more often than not, however in this situation I dislike the results it's. How do i disable this behavior?

Check for those who have "content-settlement" allows. This is a feature that allows the server deduce the file title from only the not-suffixed title with respect to the asked for client preferences, which could make the behavior you describe.