Lately I attempted to create an evaluation server with apache. The website must run under domain world wide web.mytest.com. However I always get 403 forbidden error. I'm on ubuntu 10.10 server edition. The doc root is under dir /var/world wide web. Following are my configurations:

Content of /var/world wide web

ls -l /var/www/

total 12
drwxr-xr-x 2 root root 4096 2011-08-04 11:26 mytest.com
-rwxr-xr-x 1 root root 177 2011-07-25 16:10 index.html

Content from the host file around the server (with ip 192.168.2.5)

cat /etc/hosts

127.0.0.1 localhost 
127.0.1.1 americano
192.168.2.5 americano.mytest.com www.mytest.com

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Site config:

<VirtualHost *>
ServerAdmin admin@mytest.com
ServerName www.mytest.com
ServerAlias mytest.com

DocumentRoot "/var/www/mytest.com"

ErrorLog /var/log/apache2/mytest-error_log
CustomLog /var/log/apache2/mytest-access_log combined

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/var/www/mytest.com">
Options -Indexes FollowSymLinks
AllowOverride None

Order allow,deny
Allow from all
</Directory>
</VirtualHost>

I've numberhtaccess file during my doc root. The permission can also be set properly (readable by world wide web-data).

Basically key in ip from my desktop, the website appear properly. After which I transformed the host file on my small desktop to suggest world wide web.mytest.com towards the server's IP. After which I recieve 403. Because so many functions of the website is site title sensitive, I must have the ability to access the website by domain title.

Another funky factor is, even when all log files are produced correctly, they've no specifics of this error.

I'm stuck. Can anybody help?

thanks!

This might be a permissions problem.

each and every parent road to the virtual document root should be Readable, Writable, and Executable through the web server httpd user

based on this site about Apache 403 errors.

Since you are using Allow from all, your order should not matter, but you could try switching it to Deny,Allow to create the default behavior to "permitting."