I admin two different blogs. Both are wordpress 2.8.6 (so that they have the identical source code, plug ins apart) but they're situated on two different hosting platform (hostmonster.com and aruba.it). To describe my problem I have left with SmartSniff a session with all the sites.

This is actually the dump from hostmonster:

GET /blog/paolo/ HTTP/1.1
Host: www.e-venturi.com
Accept-Encoding: identity
Accept-Language: en-us
Accept: text/html, text/plain, text/xml, image/gif, image/x-xbitmap, image/x-icon,image/jpeg, image/pjpeg, application/vnd.ms-powerpoint, application/vnd.ms-excel, application/msword, */*
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0;)


HTTP/1.1 200 OK
Date: Sat, 28 Nov 2009 23:47:38 GMT
Server: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8l DAV/2 mod_auth_passthrough/2.1 FrontPage/5.0.2.2635
X-Powered-By: PHP/5.2.11
X-Pingback: http://www.e-venturi.com/blog/paolo/xmlrpc.php
Vary: Accept-Encoding
Transfer-Encoding: chunked
Content-Type: text/html; charset=UTF-8

a6
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

and today from aruba:

GET /blog/ HTTP/1.1
Host: www.cubanite.net
Accept-Encoding: identity
Accept-Language: en-us
Accept: text/html, text/plain, text/xml, image/gif, image/x-xbitmap, image/x-icon,image/jpeg, image/pjpeg, application/vnd.ms-powerpoint, application/vnd.ms-excel, application/msword, */*
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0;)


HTTP/1.1 200 OK
Date: Sat, 28 Nov 2009 23:49:19 GMT
Server: Apache/2.2
X-Pingback: http://www.cubanite.net/blog/xmlrpc.php
Vary: Accept-Encoding
Transfer-Encoding: chunked
Content-Type: text/html; charset=UTF-8

100b
...<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

(note: a6 and 100b would be the packet size reported by SmartSniff)

Ok, the large difference would be the three dots while watching <!DOCTYPE in aruba. Those are the UTF-8 BOM (0xef 0xbb 0xbf).

Being exactly the same PHP source on the servers, how come it seems only on a single server ?

This content is produced therefore the publish author can't deliberately place a BOM and I have verified web site to become BOM free too. Naturally you will find different PHP and Apache versions around the servers... so what can I check or set to identify and resolve the issue ? Incidentally I'm not going the BOM.

Thank you ahead of time.

The BOM is within the PHP source files prior to the opening <?php. From time to time, this could appear since you seen the origin inside a poorly written text editor, used an FTP client having a bug, used an unzip tool that instantly put within the BOM, got the origin code from the shady mirror, etc. etc.

My option would be to spread out in the primary Wordpress files (index.php, wp-*.php, etc.) in Notepad++ and switch the format from Home windows/Mac to Unix and switch off the BOM. This can cleanup the files associated with a source issues.

The main reason you are seeing it in a different way on two different servers might be since the servers are running two different server programs or two different os's (as well as getting two different designs). The woking platform differences would result in your servers delivering out their own interpretation from the BOM.

Hope this can help!