I wish to install Bugzilla on my small linux server. Cellular phone was effective, however it gives this error:


TEST-Unsuccessful Web Server isn't performing CGI files

How you can resolve this?

In the Bugzilla configuration guide:

2.2.4.1. Apache httpd

To configure your Apache web server to utilize Bugzilla, perform the following:

  1. Load httpd.conf inside your editor. In Fedora and Red-colored Hat Linux, this file can be found in /etc/httpd/conf.
  2. Apache uses directives allowing fine-grained permission setting. Add the next lines to some directive that is applicable towards the location of the Bugzilla installation. (If this type of section doesn't exist, you will want to add one.) Within this example, Bugzilla continues to be installed at /var/www/html/bugzilla.

Take a look:

<Directory /var/www/html/bugzilla>
   AddHandler cgi-script .cgi
   Options +Indexes +ExecCGI
   DirectoryIndex index.cgi
   AllowOverride Limit
</Directory>

These instructions allow Apache to operate .cgi files within the bugzilla directory instructs the server to search for personal files known as index.cgi if a person only types your directory title in to the browser and enables Bugzilla's .htaccess files to override global permissions.

Altering SELinux configurations to permissive labored for me personally.

In Fedora Core and RedHat Enterprise, edit /etc/selinux/config and you'll see some lines such as this:

This file controls the condition of SELinux around the system.

SELINUX= may take one of these simple three values:

enforcing - SELinux security policy is enforced.

permissive - SELinux prints alerts rather than enforcing.

disabled - No SELinux policy is loaded.

SELINUX=enforcing

SELINUXTYPE= may take one of these simple two values:

specific - Only specific network daemons are safe.

strict - Full SELinux protection.

SELINUXTYPE=specific

... just change SELINUX=enforcing to SELINUX=permissive, and you are done.

You could try to see the Apache documentation, it will contain all you need.

i've added this during my httpd.conf file

Options +Indexes +FollowSymLinks +ExecCGI

DirectoryIndex index.cgi

AllowOverride Limit

Order allow,deny
Allow from all

AddHandler cgi-script .cgi

however too ienc states TEST-Unsuccessful Web Server isn't performing CGI files Do i wish to add ScriptInterpreterSource Registry-Strict to really make it run