I'm wishing someone might help me. I've a credit card applicatoin which has security using ricocheting's SQL Wrapper and Login Singleton for PHP. I'm installed your blog within the root directory of my application which requires user qualifications to gain access to. I'm attempting to wrap the primary blog index.php page with my login singleton however i have an error. The code and also the error are the following:

<?php
/**
* The main template file.
*
* This is the most generic template file in a WordPress theme
* and one of the two required files for a theme (the other being style.css).
* It is used to display a page when nothing more specific matches a query.
* E.g., it puts together the home page when no home.php file exists.
* Learn more: http://codex.wordpress.org/Template_Hierarchy
*
* @package WordPress
* @subpackage Twenty_Eleven
*/
include_once(ABSPATH . 'includes/config.php');
include_once(ABSPATH . 'includes/Database.singleton.php');
include_once(ABSPATH . 'includes/Login.singleton.php');

$db = Database::obtain(DB_SERVER, DB_USER, DB_PASS, DB_DATABASE);
$db->connect();

//$login = Login::obtain(); // object login

// make user login (requires admin status)
//$login->hard(1);

get_header(); ?>

<div id="primary">
<div id="content" role="main">

<?php if ( have_posts() ) : ?>

<?php twentyeleven_content_nav( 'nav-above' ); ?>

<?php /* Start the Loop */ ?>
<?php while ( have_posts() ) : the_post(); ?>

<?php get_template_part( 'content', get_post_format() ); ?>

<?php endwhile; ?>

<?php twentyeleven_content_nav( 'nav-below' ); ?>

<?php else : ?>

<article id="post-0" class="post no-results not-found">
<header class="entry-header">
<h1 class="entry-title"><?php _e( 'Nothing Found', 'twentyeleven' ); ?></h1>
</header><!-- .entry-header -->

<div class="entry-content">
<p><?php _e( 'Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.', 'twentyeleven' ); ?></p>
<?php get_search_form(); ?>
</div><!-- .entry-content -->
</article><!-- #post-0 -->

<?php endif; ?>

</div><!-- #content -->
</div><!-- #primary -->

<?php get_sidebar(); ?>
<?php get_footer(); ?>

My code is on lines 14-24.

The mistake I recieve is:

Database Error
Message: WARNING: No link_id found. Likely not be connected to database.
Could not connect to server: [server name].
Date: Monday, October 24, 2011 at 3:53:13 AM
Script: /fitzwad/marsecdev/
Database Error
Message: WARNING: No link_id found. Likely not be connected to database.
Could not open database: [database name]
Date: Monday, October 24, 2011 at 3:53:13 AM
Script: /fitzwad/marsecdev/ 

Clearly it is not hooking up towards the database but I don't know why. It connects on almost every other non-wordpress file for the reason that directory although not the wordpress files. Can there be some form of wordpress configuration obstructing other databases from being went?

Any help could be greatly appreciated.

Thanks ahead of time - Brent