Okay, for whatever reason today, I'm not able for connecting towards the Wordpress SVN repository and execute fundamental svn instructions (e.g. checkout, update).

Here's a good example of what is happening:

$ svn co http://svn.automattic.com/wordpress/tags/3.3/
# Adds a bunch of files...

svn: warning: Error handling externals definition for '3.3/wp-content/plugins/akismet':
svn: warning: PROPFIND of '/!svn/vcc/default': could not connect to server (http://plugins.svn.wordpress.org)
Checked out revision 19597.

$ cd 3.3
$ svn update
svn: OPTIONS of 'http://svn.automattic.com/wordpress/tags/3.3': could not connect to server (http://svn.automattic.com)

Yet, after i perform the instructions on the development server I've (a Linode VPS) it really works fine.

I have google about this a great deal, and located pages such as these:

Many of these articles say something to effect of, it is your proxy server. Well, I am not behind a proxy server:

http://whatismyipaddress.com/proxy-check

Proxy server not detected.

IP  24.21.xxxx.xxx
rDNS    FALSE
WIMIA Test  FALSE
TOR Test    FALSE
Loc Test    FALSE
Header Test FALSE
DNSBL Test  FALSE

Only a regular old Comcast home web connection.

Also, I'm able to see the wordpress SVN repository all right via my browser.

Anyhow, I am kind of in a stalemate here, and that i guess I am wondering if anybody has any suggestions regarding how you can either solve the problem or deal with it? I attempted establishing an forward proxy server around the Apache installation I've running on that dev server after which upgrading my ~/.subversion/server file, but that did not work or I set up a problem.

Well, if anybody has any brilliant ideas or explanations, I'd like to hear them...

Update

I'd a co-worker test this on his home connection -- he makes use of Comcast too. He got the same error when i did. Therefore it seems to become some Comcast-related problem specific towards the Wordpress svn repository. I could checkout other public databases via http (e.g. from Google Code) all right.

I went a number of tests and that i couldn't find any hidden proxies or cache servers between me and also the repository.

Used to do run traceroute per Lazy Badgers suggestion, and this is what I acquired:

$ traceroute svn.automattic.com
traceroute to svn.automattic.com (72.233.56.196), 64 hops max, 52 byte packets
 1  192.168.1.1 (192.168.1.1)  0.659 ms  0.292 ms  0.185 ms
 2  * * *
 3  te-5-7-ur01.hollywood.or.bverton.comcast.net (68.85.150.225)  8.792 ms  8.309 ms  9.054 ms
 4  xe-3-1-0-0-ar03.beaverton.or.bverton.comcast.net (68.87.216.33)  14.354 ms  24.859 ms  8.753 ms
 5  pos-3-8-0-0-cr01.sacramento.ca.ibone.comcast.net (68.86.95.117)  21.869 ms
    pos-3-1-0-0-cr01.sacramento.ca.ibone.comcast.net (68.86.95.113)  21.791 ms
    pos-3-0-0-0-cr01.sacramento.ca.ibone.comcast.net (68.86.95.109)  22.983 ms
 6  pos-0-7-0-0-cr01.sanjose.ca.ibone.comcast.net (68.86.85.46)  23.682 ms  25.043 ms  24.675 ms
 7  xe-10-3-0.edge1.sanjose1.level3.net (4.71.118.5)  61.048 ms  23.986 ms  24.221 ms
 8  vlan80.csw3.sanjose1.level3.net (4.69.152.190)  25.257 ms  25.648 ms
    vlan90.csw4.sanjose1.level3.net (4.69.152.254)  24.310 ms
 9  ae-82-82.ebr2.sanjose1.level3.net (4.69.153.25)  24.870 ms
    ae-92-92.ebr2.sanjose1.level3.net (4.69.153.29)  25.371 ms
    ae-91-91.ebr1.sanjose1.level3.net (4.69.153.13)  24.744 ms
10  ae-34-34.ebr4.sanjose1.level3.net (4.69.153.34)  36.011 ms  25.975 ms  36.053 ms
11  ae-5-5.ebr2.sanjose5.level3.net (4.69.148.141)  25.236 ms  25.307 ms  25.305 ms
12  ae-6-6.ebr2.losangeles1.level3.net (4.69.148.201)  31.299 ms  34.076 ms  33.401 ms
13  ae-3-3.ebr3.dallas1.level3.net (4.69.132.78)  59.012 ms  58.604 ms  60.576 ms
14  ae-83-83.csw3.dallas1.level3.net (4.69.151.157)  59.708 ms  65.724 ms
    ae-73-73.csw2.dallas1.level3.net (4.69.151.145)  60.383 ms
15  ae-42-90.car2.dallas1.level3.net (4.69.145.196)  60.636 ms
    ae-22-70.car2.dallas1.level3.net (4.69.145.68)  59.572 ms  59.758 ms
16  databank-ho.car2.dallas1.level3.net (4.71.170.2)  58.711 ms  59.994 ms  60.561 ms

I'm not sure if that is unusual or anything. I attempted exactly the same on my small dev sever and also the result looked mostly similar, save for line 2 using the * * *.

I effectively set up a forward proxy on my small dev server so I have compromised together an answer for the time being, however i still don't quite know very well what is afoot...

Update 2

In reaction to some question, here's the way i set up items to use my dev server like a proxy for the moment.

First, I set up apache on my small dev server to operate like a proxy. Make certain these directives are somewhere inside your Apache configuration file chain (httpd.conf, vhosts.d directory, etc.):

Listen 8080

<VirtualHost _default_:8080>
    ProxyRequests On
    ProxyVia On
    ProxyPreserveHost On

    <Proxy *>
        Order deny,allow
        Deny from all
        Allow from xxx.xxx.xxx.xxx
    </Proxy>
</VirtualHost>

This assumes you've got a working Apache set on an improvement server somewhere (I'd certainly not make use of this on the production server) with mod_proxy installed. Port 8080 is arbitrary. Essentially to have an unmatched virtual host (i.e. any request that does not suit your other hosts you've setup) it'll turn proxy on and proxy the request through. Change "xxx.xxx.xxx.xxx" for your own Ip.

Now you must to alter the server establishing your subversion config file.

Within this file:

~/.subversion/servers

Find this:

[global]
# http-proxy-exceptions = *.exception.com, www.internal-site.org
# http-proxy-host = proxy1.some-domain-name.com
# http-proxy-port = 80
# http-proxy-username = defaultusername
# http-proxy-password = defaultpassword
# http-compression = no
# http-auth-types = basic;digest;negotiate
# No http-timeout, so just use the builtin default.
# No neon-debug-mask, so neon debugging is disabled.
# ssl-authority-files = /path/to/CAcert.pem;/path/to/CAcert2.pem

Uncomment out http-proxy-host and http-proxy-port. For host make use of a spare domain title you've planned for your development server or most probably you can only use your server IP. Then set the main harbour to 8080 or anything you used.

This will route all subversion http demands via your proxy you simply setup. It does not affect svn or svn+ssh demands.

It was my quick hack, your mileage can vary, this can be totally insecure or damaged, etc.