Getting issues while using PHP memcached class.

I'm managing a Light atmosphere on Ubuntu 10.10 with Apache 2.2.16 and PHP 5.3.3. I've just installed things i thought was memcached, but appears possibly to become memcache?

I'm able to begin a new memcache object with:

$m = new Memcache;

Which works fine. However when I attempt and begin a memcached object

$m = new Memcached();

I recieve the next error

Fatal error: Class 'Memcached' not found

After I run 'ps -A grep Memcache' with the console, it returns

ben@ben-computer:/tmp$ ps -A | grep memcache
1214 ?        00:00:00 memcached

Showing a running memcached process. phpinfo() returns memcache version 5.2.6.

However when I look further into etc folder

ben@ben-computer:/etc/default$ cat memcached 
# Set this to no to disable memcached.
ENABLE_MEMCACHED=yes

When i run php -m it returns memcache.

You type of obtain the picture, i've no clue why memcache is running rather than memcached, any help could be great.

Edit:

It happens to be an problem with libmemcached. I installed the libmemcached-dev package, although not confident that this is the same?

Memcache = title of sophistication
Memcached = title of daemon that runs class

Similarly, cron and crond, mysql and mysqld.

You will find two different PHP classes which you can use. I suggest memcached over memcache since it is more recent and supports more features.

The memcached extension isn't a standard element of PHP, and should be installed individually from PECL. Instructions are online at:

http://php.net/memcached.installation