I am attempting to install zend debugger during my Ubuntu 9.04 machine, I have tried it in win. although not in linux, I think you'll may help me, this is exactly what I have done:

1)Replicated the file ZendDebugger.to /etc/php5/apache2 (did not choose this folder for anything in special).

2)Added this lines to php.ini:

zend_extension="/etc/php5/apache2/ZendDebugger.so" zend_debugger.allow_hosts=127...1,127..1.1,localhost,*
zend_debugger.expose_remotely=always

I have also attempted without quotes(zend_extension=/etc/php5/apache2/ZendDebugger.so)

3)Replicated file dummy.php to /var/world wide web

After which restarted Apache however i did not begin to see the details about Zend Debugger within the phpinfo(), the only real related factor I discovered there is report_zend_debug On.

Thanks ahead of time

sudo mv /etc/php5/apache2/ZendDebugger.so /usr/lib/php5/20060613/ZendDebugger.so

This is when your memcache.so, apc.so, etc. are situated. Unless of course you modified your php extensions directory that's where new exts is going.

In php.ini:

zend_extension=/usr/lib/php5/20060613/ZendDebugger.so

compact disc to that particular directory and chmod a-x ZendDebugger.so to get rid of executable bits in the .so.

sudo /etc/init.d/apache2 stop

In another terminal window, tail -f /var/log/error.log and obvious console so you can easily see new log records arriving (cmd-k on macos).

Then:

sudo /etc/init.d/apache2 start

If you will find no errors in error.log, check phpinfo() if the debugger section turns up.

You can find errors within the configuration of other php extensions that occur further up in php.ini (e.g., xcache or eaccellerator) that can make loading stuff further lower in php.ini problematic.

This can be a baseline setup and really should work if you will find not one other problems.

I discovered a lot more simple to install Xdebug during my Ubuntu machine.

You may also attempt to install Zend Server Community Edition You will get Zend Debugger enabled automatically, together with another nice features. There's a hyperlink towards the n repository available with the download page.

I adopted exactly the same steps that you simply did with similar result. Ultimately the issue was which i was attempting to load a 32bit binary with apache running in 64bit mode base (as referred to within this post) I could have it running immediately by doing the next.

  1. preventing apache
  2. performing sudo arch -i386 /usr/sbin/httpd
  3. restarting apache.

After changing the 32bit binary using the 64bit binary everything labored not surprisingly without any special apache handling. There is several facepalming involved, but it didn't modify the overall outcome.