I have researched this and could'nt find anything new and helpful for Apple's new OS SnowLeopard. I question if this sounds like my mistake or I need to make a move?

this is exactly what Used to do:

Downloaded from mysql site: http://dev.mysql.com/downloads/mysql/5.1.html#macosx-dmg I select : Mac OS X 10.5 (x86_64)

I run all of the packages and installed these. Now I certainly have mysql in

/usr/local/mysql/

However when attempting to start it from preferences panel, it is usually STOPPED. After I attempt to do (within the terminal):

/usr/local/mysql/bin/mysql

I acquired :

-party: /usr/local/mysql/bin/mysql: Bad CPU key in executable

What's wrong here? Any help could be very appreciated. Thanks

Maybe this answer helps:

mysql5.58 unstart server in mac os 10.6.5

I simply installed MySQL 5.5.8 (mysql-5.5.8-osx10.6-x86_64.dmg) on Mac os X 10.6.5 as well as had the issue that MySQL wasn't beginning.

After reading through this publish: http://forums.mysql.com/read.php?11,399397,399606#monosodium glutamate-399606 and editing the file as recommended everything began working.

I additionally did

sudo chown -R root:wheel /Library/StartupItems/MySQLCOM

after reading through http://discussions.info.apple.com/message.jspa?messageID=12820394#12820394 for how long restarting my Macosx 10.6.6 it continued asking something about insufficient rights. The road above solved that problem.

Now things are working.

You Have To Re-install mySQL after improving to Snow Leopard and take away any previous versions in addition to previous startup in the preference panel. install 86_64 10.5...I've found others didn't work with me.

  1. Download MySQL version Mac OS X 10.5 (x86_64) situated at http://dev.mysql.com/downloads/mysql/5.4.html#macosx-dmg
  2. Install startup Item (follow instructions)
  3. Then install the beta version (follow instructions)
  4. If you would like the beginning up within the Preference Panel...install mySQL.prefpane I've found that SQL doesn't run in the terminal unless of course you begin mySQL within the preference panel.

Okay... Finally I possibly could do the installation! Why? or things i did? well I don't know. first I downloaded and installed the package (I installed all of the files(3) in the disk image) however i could not start it. (nor in the preferences panel, nor in the termial)

second I took it off and installed through mac ports.

again, exactly the same factor. couldn't start it.

Now I erased it again, installed in the package. (i don't know whether it was the identical package but It is) Only this time around I acquired the package from another site(its one).

the website:

http://world wide web.mmisoftware.co.united kingdom/website/2009/08/29/mac-os-x-10-6-snow-leopard-and-mysql/

and also the link:

http://mirror.services.wisc.edu/mysql/Downloads/MySQL-5.1/mysql-5.1.37-osx10.5-x86.dmg

1.- install mysql-5-1.37-osx10.5-x86.pkg

2.- install MySQLStartupItem.pkg

3.- install MySQL.prefpanel

And this time around is working fine (the preferences panel!)

Nothing special, I'm not sure what went down the very first two occasions.

But thanks all. Regards.