Hey i understand you will find a couple of posts in regards to this subject and that i have searched all of them!

I am unable to not let the display_errors establishing php regardless of what i actually do!!!

Im using virtual box with php 5.3 installed with apache2 running. i've attempted everything i'm able to think about to obtain display errors working but nothing appears to operate.

I've set php_flag display_errors on during my .htaccess file i've even enabled it directly within the php.ini file

display_errors = 1

as well as attempted

display_errors = On

I'm while using defaults for apache sites-enabled can there be something i have to do here to get this work?? i have not had this issue running php on my small mac using mamp.

Any suggestions could be greatly appreciated this really is driving me nuts!

You may also enable it inside your PHP script usually:

ini_set("display_errors", 1);
ini_set("track_errors", 1);
ini_set("html_errors", 1);
error_reporting(E_ALL);

In the event that does not help, then consider using a quick workaround first:

set_error_handler("var_dump");

(Could be employed to replicate the initial behavior, whether it's covered up by another circumstance.)

Try error_reporting = E_ALL. Also, are you certain that you're editing the right php.ini?

It's my job to use (within the PHP script I attempt to debug):

ini_set('display_errors',1);
ini_set('display_startup_errors',1);
error_reporting(E_ALL);

That always does the task, but when you've got a nasty unmatched parenthesis it couldn't suffice. Therefore if it does not still work, it might rely on some PHP buggy code.

It can also be that you're editing the incorrect php.ini: use phpinfo() and check for that parts under "Loaded Configuration File" and "Additional .ini files parsed".

P.S. : display_errors = 1 and display_errors = On in php.ini are equivalent.