I installed wordpress Mu at http://www.optimalthinking.com/community/wp-admin/install.php

However when I visit http://www.optimalthinking.com/community/

I recieve

Security Alert! The PHP CGI can't be utilized directly.

This PHP CGI binary was put together with pressure-cgi-redirect enabled. What this means is that the page are only offered up if the REDIRECT_STATUS CGI variable is set, e.g. with an Apache Action directive.

To learn more why this behavior is available, begin to see the manual page for CGI security.

To learn more about altering this behavior or re-enabling this webserver, consult cellular phone file that included this distribution, or go to the manual page.

Can anybody let me know what is the problem and just how it may be fixed.

A Few Things I have attempted to date:

  1. Reinstalled the WPMU
  2. http://mu.wordpress.org/forums/topic/5529
  3. http://trac.mu.wordpress.org/ticket/502
  4. Attempted altering .htaccess

Each one of these things didnt yield any improvements. If stackoverflow enables me, I'd reward anyone who would fix this.

Thanks

For me it have something related to your configuration, for many reasons script attempting to redirect user to cgi-bin folder that is private.

From http://us3.php.net/security.cgi-bin

PHP CGI with VirtualHosts.

This is what I found out while trying to get php to work as CGI with Apache VirtualHosts.

By enabling 'force-cgiredirects', you *must*:
1) set 'cgi.fix_pathinfo=1' in php.ini
2) leave doc_root commented out (php.ini also)

If you miss item 1, the apache logs will show 'unexpected T_STRING' in the php binary.
If you miss item 2, you'll only see 'No input file specified.', instead of the expected output.

You can then turn on the php support for a particular vhost by defining:

Action php-script /cgi-bin/php

inside the corresponding <VirtualHost> directive.

Cheers.

You have to fix your php.ini

Add/fix this line:

force_cgi_redirect = 0

Thanks to FAQTS and Google