I'm focusing on a publish type form. The website is wordpress based. While testing the shape, I observed that each time I personally use the ''' character, once the publish is published, it prints out "'" rather.

For instance:

Input: "Bob's birthday plans." Output: "Bob's birthday plans."

How do you stop php or wordpress, whichever is responisble, from carrying this out?

Individuals are Magic Quotes, probably the most questionable options that come with PHP.

It's an option in PHP.ini, you need to speak to your hosting service and also have them shut them back (Or search for the choice yourself, if you're fortunate enough to).

Might be magic_quotes_gpc as well as worse magic_quotes_runtime.

This feature continues to be DEPRECATED by PHP 5.3. and REMOVED by PHP 6... Depending about this feature is extremely frustrated.
[...]
When miracle_quotes take presctiption, all ' (single-quote), " (double quote), (backslash) and NUL's are steered clear of having a backslash instantly.

There appears to become a trouble with magicquotes and based on this site, the fix consists in adding the next lines for your theme file:

if ( get_magic_quotes_gpc() ) {
    $_POST      = array_map( 'stripslashes_deep', $_POST );
    $_GET       = array_map( 'stripslashes_deep', $_GET );
    $_COOKIE    = array_map( 'stripslashes_deep', $_COOKIE );
    $_REQUEST   = array_map( 'stripslashes_deep', $_REQUEST );
}

Which may translate to something similar to, if miracle quotes are enabled, take away the slashes from individuals variable arrays. Therefore repairing your problem.