I am attempting to configure home server to simply accept SSL Connection on port 443.

I have www.mydomain.com domain, I have just linked Apache2 and Tomcat, using mod_jk, now If only to simply accept also https request on the internet.

This really is my configuration:

httpd.conf

<IfModule mod_jk.c>
    JKWorkersFile /etc/apache2/workers.properties
    JkShmFile /var/log/apache2/mod_jk.shm
    JKLogFile /var/log/apache2/mod_jk.log
    JkLogLevel debug
    JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
</IfModule>


<VirtualHost *:80>
    DocumentRoot "/Library/ApacheTomcat/apache-tomcat-6.0.33/webapps/MyTomcatAppName"
    ServerName www.mydomain.com
    ErrorLog "/private/var/log/apache2/www.mydomain.com-error_log"
    CustomLog "/private/var/log/apache2/www.mydomain.com-access_log" common
    JkMountCopy On
    JkMount /* ajp13
</VirtualHost>


<VirtualHost *:80>
    DocumentRoot "/Library/ApacheTomcat/apache-tomcat-6.0.33/webapps/MyTomcatAppName"
    ServerName mydomain.com
    ErrorLog "/private/var/log/apache2/mydomain.com-error_log"
    CustomLog "/private/var/log/apache2/mydomaino.com-access_log" common
    JkMountCopy On
    JkMount /* ajp13
</VirtualHost>

Than the is my Worker.qualities file:

worker.list=ajp13

worker.ajp13.type=ajp13
worker.ajp13.host=localhost
worker.ajp13.port=8009

This really is my server.xml:

    <Host name="localhost"  appBase="/Library/ApacheTomcat/apache-tomcat-6.0.33/webapps"
        unpackWARs="true" autoDeploy="true"
        xmlValidation="false" xmlNamespaceAware="false">
      <Context path="" docBase="/Library/ApacheTomcat/apache-tomcat-6.0.33/webapps/MyTomcatAppName" />

With this particular configuration I properly surf MyTomcatAppName after i visit http:// www.mydomain.com or http:// domain.com... My problem now's to go to exactly the same website utilizing an https connection, so https:// www.mydomain.com or https:// domain.com. I in addition have a GoDaddy certificate placed on my Mac Small Server (Lion osx), therefore if I type https:// www.mydomain.com (or https:// domain.com) the browser properly inform me about the existence of certificates for "mydomain.com", it states:

Forbidden

You don't have permission to access / on this server.
Apache/2.2.20 (Unix) mod_ssl/2.2.20 OpenSSL/0.9.8r DAV/2 mod_jk/1.2.30 Server at mydomain.com Port 443

I am sure the reason being I skipped something in Virtual Host tag.... So how do i repair it?

You've set up mod_jk inside your virtual hosts for plain HTTP demands (VirtualHost *:80). You have to configure these Jk* options within the HTTPS virtual hosts too (VirtualHost *:443), in which you have set up your SSL configurations.