I've VM (Ubuntu 10.04, Apache, CouchDB 1., ...) with public ip.

  • Can you really access CouchDB (mainly Futon) from public ip (i.e. 187.323.132.232:5984), not from http://localhost:5984?
  • Or on my small local machine, setup an ssh tunnel?
  • Yes, visit the Futon Configuration and hang bind_address within the http section to 0.0.0.0
  • Alternatively, you should use SSH also. The fundamental idea would be to forward out of your local machine towards the remote CouchDB:

    ssh -L 5984:localhost:5984 remoteuser@remotemachine
    

    You can now access Futon via http://localhost:5984/ in the local machine.

Best of luck!

You may also proxy via Apache:

    ProxyRequests Off

    <Proxy *>
            Order deny,allow
            Allow from all
    </Proxy>

    ProxyPass / http://localhost:5984/
    ProxyPassReverse / http://localhost:5984/

It's also wise to have the ability to do that using the [P] flag on the RewriteRule, supposing mod_proxy continues to be enabled.