I wish to create crosstab function for that postgresql database version 8..1 Since it was implemented after postgresql 8.4. . I'm not table to make use of the same function. Can there be in whatever way for your ?

PostgreSQL 8..1?!?

PostgreSQL 8..x is unsupported, but when you are still running 8..1 you do not mind about this since you haven't applied any patches. You're managing a release with multiple known loss of data bugs. You have to upgrade to - at least - the most recent 8..x release, then start planning your proceed to 9. or 9.1 fairly urgently.

That'll solve your present problem like a handy side-effect.