I simply installed cufon on my small wordpress but it's spacing out my sentences.. such as this..

does anybody understand how i'm able to fix that?

http://singlecutbeer.com/2011/07/hello-world-2/

that space in between each paragraph wasn't there prior to the font-alternative.

Cufon can be quite difficult to style, the simplest method of doing it's to find the "complete" option whenever you create the font. I would suggest using:

@font-face {
    font-family: font;
    src: url('font.ttf');
}

and cufon like a fallback for IE7-8

Best wishes, Marten

Building on moffepoffe's answer, make use of the font-face generator at font squirrel. Make sure to look at your licenses, but technically an excellent solution.