I have attempted dealing with Network Solutions technical support but did not have it resolved ("You have to speak with Signature Support, that is $50"). I am running some sites from a Internet Sol VPS account and want to alter the upload_max_filesize setting (that is apparently set to some paltry 2MB automatically) for that php server. I have added:

upload_max_filesize = 20M
post_max_size = 20M
max_execution_time = 6000

towards the /httpdocs/cgi-bin/php.ini file (per NS's instructions), after which restarted apache, however when I operate a phpinfo on that domain, the configurations aren't applied. Still it states "2M" for that upload max.

I additionally attempted adding this towards the server root at /cgi-bin/php.ini too, to no effect.

There's no /cgi-bin/.php/php.coalesced.ini file will be able to see.

Any ideas? I am losing my thoughts with this particular.

First thought would be to look at your phpinfo() output for that value indexed by the "Loaded Configuration File" setting and make certain it matches the file you have been editing.

You cannot just litter PHP.ini files around and expect PHP to load them. When not learned to search for one for the reason that cgi-bin directory, the file will just get overlooked.

Look into the phpinfo() output - the very first section will explain precisely what .ini files were situated/parsed, as well as their location. e.g. on my small home server:

Configuration File (php.ini) Path   /etc/php5/apache2
Loaded Configuration File   /etc/php5/apache2/php.ini
Scan this dir for additional .ini files     /etc/php5/apache2/conf.d
Additional .ini files parsed    /etc/php5/apache2/conf.d/curl.ini, /etc/php5/apache2/conf.d/gmp.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini 

in case your cgi-bin .ini file is not listed, then PHP isn't searching for the reason that directory.