I am a new comer to developing Silverlight application and that i got an problem using the database connection after implementing the applying (I'm able to access the applying all right, however i can't login because of the database problem).

Below is my error message


Unhandled Error in Silverlight Application Load operation unsuccessful for query 'Login'. The remote server came back a mistake: NotFound.

   at System.ServiceModel.DomainServices.Client.OperationBase.Complete(Exception error)

   at System.ServiceModel.DomainServices.Client.ApplicationServices.AuthenticationOperation.Finish(IAsyncResult result)

   at System.ServiceModel.DomainServices.Client.ApplicationServices.AuthenticationOperation.c__DisplayClass1.b__(Object condition)

   at System.ServiceModel.DomainServices.Client.ApplicationServices.AuthenticationOperation.RunInSynchronizationContext(SendOrPostCallback callback, Object condition)

   at System.ServiceModel.DomainServices.Client.ApplicationServices.AuthenticationOperation.HandleAsyncCompleted(IAsyncResult asyncResult)

   at System.ServiceModel.DomainServices.Client.AsyncResultBase.Complete()

   at System.ServiceModel.DomainServices.Client.ApplicationServices.WebAuthenticationService.HandleOperationComplete(OperationBase operation)

   at System.ServiceModel.DomainServices.Client.LoadOperation.c__DisplayClass4`1.b__(LoadOperation`1 arg)

   at System.ServiceModel.DomainServices.Client.LoadOperation`1.InvokeCompleteAction()

   at System.ServiceModel.DomainServices.Client.OperationBase.Complete(Exception error)

   at System.ServiceModel.DomainServices.Client.LoadOperation.Complete(Exception error)

   at System.ServiceModel.DomainServices.Client.DomainContext.CompleteLoad(IAsyncResult asyncResult)

   at System.ServiceModel.DomainServices.Client.DomainContext.c__DisplayClass1b.b__17(Object )

which is my connection string

<connectionStrings>  
  <remove name="LocalSqlServer" />
  <add name="LocalSqlServer" connectionString="server=.;data source=PC15\SQLEXPRESS;Initial Catalog=LodeSuiteDB;Integrated Security=True;" />
  <add name="LodeSuiteDB1Entities" connectionString="metadata=res://*/Model1.csdl|res://*/Model1.ssdl|res://*/Model1.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=PC15\SQLEXPRESS;initial catalog=LodeSuiteDB;integrated security=True;multipleactiveresultsets=True;App=EntityFramework&quot;" providerName="System.Data.EntityClient" />
</connectionStrings>

Does anybody have a similar problem? I am using Visual Studio 2010 Ultimate Edition and SQL Server 2008 for my development (both running on Home windows 7) whereas my IIS server (IIS 5.1) is running on Home windows XP Professional

I have been attempting to solve this issue for several days without any avail. Your assistance is greatly appreciated!

The issue is going to be the ASPNET_Wordpress process (which hosts the ASP.Internet code on IIS5.1) will run underneath the identity from the ComputerName/ASPNET account.

As you are using Integrated Peace of mind in you connection strings that account have to have been granted accessibility SQL databases being utilized.

Alternatively, you have to enable impersonation within the web.config and specify the account information of the account that does have the databases.

I do not think this can be a database connection problem. The problem here looks a lot more like the Silverlight application can't speak with the applying server over WCF RIA Services. Have a look at a few of the RIA service calls using Fiddler and find out if them are showing errors.

This link has more help concerning how to fix an RIA Services NotFound error.