Ok, this really is funny. I simply installed a wordpress, and also the images aren't showing up. Firebug informs me I recieve a 403 forbidden error for the images. However, basically copy the url in to the address bar, I recieve the look with no problem.

I do not have it (that is ok, thinking about it's almost 3 within the evening)

Ok, the issue was hotlinking protection, which doesn't seem sensible anyway, since i have am querying from inside exactly the same host. I disabled it and today it really works.

It should be searching in the Referer header.