I am developing an internet site which utilizes wordpress-cumulus on its home

http://www.roytanck.com/2008/03/06/wordpress-plugin-wp-cumulus-flash-based-tag-cloud/

it is a expensive aspect of show a pleasant cloud tag.

to be able to utilize it I problem:

<script type="text/javascript">
[...]
flashvars.tagcloud = "<tags><a href='/tag.php?tag=Marinetti'>Marinetti</a><a href='/tag.php?tag=lang'>Lang</a></tags>";
[...]
</script>

and also at the house page (index.php) I problem a redirect like

<?
header( 'Location: http://ludion.com.ar/home.php' );
exit;
?> 

however , when rerouted php instantly adds an &PHPSESSIONID=xxxx to each link, yes, incorporated the javascript stuff!!!

resulting:

<script type="text/javascript">
[...]
flashvars.tagcloud = "<tags><a href='/tag.php?tag=Marinetti&PHPSESSID=75f82a44003ee8c421dda3db52ad1f93'>Marinetti</a><a href='/tag.php?tag=lang&PHPSESSID=75f82a44003ee8c421dda3db52ad1f93'>Lang</a></tags>";
[...]
</script>

and also the componente does not appear to love ampersand, therefore it just does not work...

how do i prevent php from adding that stuff?

I have already attempted with:

ini_set( 'session.use_cookies', true );
ini_set( 'session.use_trans_sid', false );

in index.php, however it did not work

I additionally attempted creating and .htaccess file at the bottom using the following content:

php_value session.use_only_snacks 1 php_value session.use_trans_sid

with

php_flag session.use_only_snacks 1 php_flag session.use_trans_sid

however the sites just dangles-up, using the following errors within the log

[Mon Jan 11 12:01:13 2010] [alert] [client 201.250.119.217] /www/paperwork/ludion.com.ar/public_html/.htaccess: Invalid command 'php_value', possibly misspelled or based on a module not incorporated within the server configuration ...

[Mon Jan 11 12:11:27 2010] [alert] [client 201.250.119.217] /www/paperwork/ludion.com.ar/public_html/.htaccess: Invalid command 'php_flag', possibly misspelled or based on a module not incorporated within the server configuration

any idea???

The session.use_trans_sid you mention may be the appropriate one.

The Invalid command 'php_value', possibly misspelled or based on a module not incorporated within the server configuration error message indicates that PHP is running as CGI instead of Apache module. For the reason that situation, you can't configure PHP through Apache configuration files.

Normally, CGI configurations offer custom php.ini files for every customer where one can change whatever PHP setting you are permitted to. Look at your hosting service documentation for that particulars.

Obviously, if you're the server admin you could edit the primary php.ini file.

Finally, be sure to run phpinfo() to check on if the configurations were really transformed.

to date, the only real woraround I possibly could find may be the following:

after i create the js code, I split the href, to ensure that php does not recognize it as being an url, such as this:

rather than

flashvars.tagcloud = "<tags><a href='/tag.php?tag=Marinetti'>Marinetti</a><a href='/tag.php?tag=lang'>Lang</a></tags>";

I problem

flashvars.tagcloud = "<tags><a " + "href='/tag.php?tag=Marinetti'>Marinetti</a><a " + "href='/tag.php?tag=lang'>Lang</a></tags>";

very nasty in deed, however it works...

any the actual solution is always to tell php to prevent playing around with my web addresses...