Fatal error: Allowed memory size of 18874368 bytes exhausted (tried to allocate 1481725 bytes) in __/public_html/includes/database.inc on line 224

I am getting this error exist in Drupal 6 each time I attempt to edit the next pages (sorry concerning the xx's):

hxxp://chipkin.com/fs-8700-125-stulz

hxxp://chipkin.com/fs-8700-47-dnp-30

hxxp://chipkin.com/fs8700-14-general electric-mark-iv-speedtronic

hxxp://chipkin.com/fs8700-74-veeder-root-serial-driver

We are on hosting that is shared and so i don't have the php.ini file to allocate more memory, however I am confident that isn't what's leading to the issue. Any ideas?

Certainly a memory problem -- it will likely be tough that you should operate a Drupal site on only 18 mb of memory.

Your long-term option would be to alter hosts -- you will find lots of hosts where you can adjust php.ini (within limits). Bluehost.com is a example.

A potential short-term solution is always to remove unused modules out of your modules directory. Each module utilizes some memory even when it's disabled.

Such things as caching and crippling statistics are great too, however they will not help much if you are getting memory problems on fundamental page edits.

You are able to specify the memory limit through .htaccess

Try adding the next line towards the .htaccess file inside your site's root directory:

php_value memory_limit 32M

I'm on the shared host too. This is actually the PHP.INI which i produced within the Drupal domain root folders:

[PHP]
memory_limit = 40M;
upload_max_filesize = 20M;
post_max_size 20M;
max_execution_time = 200;
max_input_time = 200;

I've forget about issues with any global limits. I don't know when the hoster can disable or override the neighborhood PHP.ini - mine doesn't, and it ought to be worth an attempt.

I am not too acquainted with Drupal, but may be the page under consideration attempting to grab a lot of data in the database? Something similar to a SELECT * to have an entire table? That could explain why one call is attempting to allocate a lot memory.

Altering hosts is definitely an option, but for the time being it might be worth seeing if something can be achieved to limit the information asked for in the database.

Regrettably the mistake message does not to much to inform you what specific request is leading to the issue - because the code making the db request is incorporated in the db library class. If you're able to inflict type of stack trace, it might help.

edit configurations.php (usually in sites/default) and add (or modify):

ini_set('memory_limit', '96M');

...or nevertheless, you need.