I'm attempting to restart Apache on CentOS 5.7 server but am obtaining the following error message after i run:

service httpd restart

httpd: Syntax error on line 37 of /usr/local/apache/conf/httpd.conf: 
Syntax error on line 9 of /usr/local/apache/conf/php.conf: 
Cannot load /usr/local/apache/modules/libphp5.so into server: 
/usr/lib64/libmysqlclient.so.15: 
version `libmysqlclient_15' not found 
(required by /usr/local/apache/modules

Basically remove line 9 during my php.conf file, Apache begins fine but clearly without php loaded.

I am not so familiar with server management and still have no clue where to start figuring out/fixing the problem and searching appears to show up results not highly relevant to my situation.

Oddly everything has worked perfectly until today and that i have absolutely no clue what may have triggered the problem.

NOTE: This can be a CentOS 5.7 x64 server using cPanel WHM

EDIT: Line 9 of my php.conf file is:

LoadModule php5_module modules/libphp5.so

Used to do lately upgrade my MySQL towards the latest version via cPanel.

Also, I've just attempted to rebuild apache using easyapache in cpanel and also got the next error message:

!! 
Here are some details that may be helpful: !! '/opt/xml2/' is up to date but looks like it has local modifications. If you experience any trouble remove '/opt/xml2/' so that it will be rebuilt fresh. !! !!