I'm running MAMP in Snow Leopard and wish to get Ruby running too. I've got Passenger seeing my MAMP install but am getting a mistake because it attempts to result in the modules I want. This is actually the output:

Checking for required software...

 * GNU C++ compiler... found at /usr/bin/g++
 * Curl development headers with SSL support... found
 * OpenSSL development headers... found
 * Zlib development headers... found
 * Ruby development headers... found
 * OpenSSL support for Ruby... found
 * RubyGems... found
 * Rake... found at /Users/mn-justinm/.rvm/wrappers/ruby-1.9.2-p180@rails3/rake
 * rack... found
 * Apache 2... found at /Applications/MAMP/Library/bin/httpd
 * Apache 2 development headers... found at /Applications/MAMP/bin/apache2/bin/apxs
 * Apache Portable Runtime (APR) development headers... found at 

/Applications/MAMP/Library/bin/apr-config
 * Apache Portable Runtime Utility (APU) development headers... found at /Applications/MAMP/Library/bin/apu-config

--------------------------------------------
Compiling and installing Apache 2 module...
cd /Users/mn-justinm/.rvm/gems/ruby-1.9.2-p180@rails3/gems/passenger-3.0.5
/Users/mn-justinm/.rvm/wrappers/ruby-1.9.2-p180@rails3/rake apache2:clean apache2 RELEASE=yes
# /Users/mn-justinm/.rvm/wrappers/ruby-1.9.2-p180@rails3/rake apache2:clean apache2 RELEASE=yes
(in /Users/mn-justinm/.rvm/gems/ruby-1.9.2-p180@rails3/gems/passenger-3.0.5)
rm -rf ext/common/libboost_oxt.a ext/common/libboost_oxt
rm -rf ext/common/libpassenger_common.a ext/common/libpassenger_common
rm -f agents/PassengerWatchdog agents/PassengerLoggingAgent
rm -rf ext/apache2/module_libboost_oxt.a ext/apache2/module_libboost_oxt
rm -rf ext/apache2/module_libpassenger_common.a ext/apache2/module_libpassenger_common
rm -rf ext/apache2/Configuration.o ext/apache2/Bucket.o ext/apache2/Hooks.o ext/apache2/mod_passenger.o ext/apache2/mod_passenger.so agents/PassengerHelperAgent
mkdir -p ext/apache2/module_libpassenger_common
g++ -Iext -Iext/common -Iext/libev -fPIC -fvisibility=hidden -DVISIBILITY_ATTRIBUTE_SUPPORTED -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -I/Applications/MAMP/Library/include -I/Applications/MAMP/Library/include -I/Applications/MAMP/Library/include -I/Applications/MAMP/Library/include -arch ppc -arch i386 -D_REENTRANT -I/usr/local/include -DHASH_NAMESPACE="__gnu_cxx" -DHASH_FUN_H="<ext/hash_fun.h>" -DHAS_SFENCE -DHAS_LFENCE -Wall -g -DPASSENGER_DEBUG -DBOOST_DISABLE_ASSERTS -o ext/apache2/module_libpassenger_common/aggregate.o -c ext/apache2/module_libpassenger_common/aggregate.cpp
/usr/libexec/gcc/powerpc-apple-darwin10/4.2.1/as: assembler (/usr/bin/../libexec/gcc/darwin/ppc/as or /usr/bin/../local/libexec/gcc/darwin/ppc/as) for architecture ppc not installed
Installed assemblers are:
/usr/bin/../libexec/gcc/darwin/x86_64/as for architecture x86_64
/usr/bin/../libexec/gcc/darwin/i386/as for architecture i386
lipo: can't open input file: /var/tmp//cckv6xPC.out (No such file or directory)
rake aborted!
Command failed with status (1): [g++ -Iext -Iext/common -Iext/libev -fPIC -...]

If anybody has any insight for this problem the assistance could be amazing, thanks!