I have produced a Apache virtual host for any Amazone EC2 private DNS. Just generate an income made it happen along with other hosts, too. However for some reasons, there's always a 403 (forbidden) when asking for it. To really make it bulletproof I have replicated the virtual host file from the working host, double checked all pathways and hosts. It's enabled and Apache configuration files are reloaded. The actual way it works together with every other host. But there's still that 403 asking for it in the same or any other EC2 instance.

# host: ip-xyz.eu-west-1.compute.internal
# directory: /var/www/xyz
<VirtualHost *:80>
 ServerName ip-xyz.eu-west-1.compute.internal
 DocumentRoot /var/www/xyz
 <Directory /var/www/xyz>
  Options FollowSymLinks
  AllowOverride All
  Order Deny,Allow
  Allow from All
 </Directory>
</VirtualHost>

Any ideas?

Sincerely, Jimbo

You can examine the mistake log (for, well, errors), and also the access log to ensure you really utilized the best machine.

Edit: If there's another wildcard VirtualHost declaration, remove it in the configuration.