I've read several lessons, however i cannot this to operate. My apache config file appears like this (using the important couple of lines at the end):

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log
    LogLevel warn

WSGIScriptAlias /wsgi/ /neuroling/projects/lnldb/lnldbproject/lnldb.wsgi
<Directory /neuroling/projects/lnldb/lnldbproject/>
  Order allow,deny
  Allow from all
</Directory>

My lnldb.wsgi file appears like this:

import os
import sys

path = '/neuroling/projects/lnldb'
if path not in sys.path:
    sys.path.append(path)

path = '/neuroling/projects/lnldb/lnldbproject'
if path not in sys.path:
    sys.path.append(path)

os.environ['DJANGO_SETTINGS_MODULE'] = 'lnldbproject.settings'

import django.core.handlers.wsgi
application = django.core.handlers.wsgi.WSGIHandler()

If Time passes to [MY_IP_ADDRESS]/wsgi with my broswer, I check this out:

While using URLconf defined in lnldbproject.web addresses, Django attempted these URL designs, within this order: ^admin/ The present URL, , did not match these.

Fair enough, I've not really trained with a URL. But a minimum of lnldb.wsgi gets known as.

But I wish to begin to see the admin, and so i visit [MY_IP_ADDRESS]/wsgi/admin, and that i just get:

Not Found The asked for URL /wsgi/admin wasn't available on this server.

Could someone please explain what I am doing wrong, I am sure it is something relatively easy...

Thanks.

Change:

WSGIScriptAlias /wsgi/ /neuroling/projects/lnldb/lnldbproject/lnldb.wsgi

to:

WSGIScriptAlias /wsgi /neuroling/projects/lnldb/lnldbproject/lnldb.wsgi

You shouldn't possess a trailing slash on mount point when mounted at sub URL to begin with.