I'm trying to produce a hosting that is shared scenario, using open_basedir use of php. I'm carrying this out with the addition of the next to apache2.conf

<VirtualHost *:80>

    ServerName lt1.example.internet

    DocumentRoot /home/akshat/example/tmpblogs/tb1/

    php_admin_value open_basedir /home/akshat/example/tmpblogs/tb1/

</VirtualHost>

<VirtualHost *:80>

    ServerName lt2.example.internet

    DocumentRoot /home/akshat/example/tmpblogs/tb2/

    php_admin_flag open_basedir /home/akshat/example/tmpblogs/tb2/

</VirtualHost>

Now after i access lt2.example.internet, I recieve the mistake:

Warning: Unknown: open_basedir restriction essentially. File(/home/akshat/example/tmpblogs/tb2/index.php) isn't inside the permitted path(s): () in Unknown online

Warning: Unknown: unsuccessful to spread out stream: Operation not allowed in Unknown online

Fatal error: Unknown: Unsuccessful opening needed '/home/akshat/example/tmpblogs/tb2/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown online

I had been obtaining the same error while being able to access "lt1.example.internet" too, however it all of a sudden grew to become okay.

What am I doing wrong here?

Found the error. It's a stupid one.

In site 2 I'm using "php_admin_flag" directive rather than "php_admin_value". Problem solved