I'm trying to setup git on my small Debian server. However, I am going insane relating to this Wise HTTP stuff, as I wish to make use of the Egit plug-set for eclipse also it requires Wise HTTP. And that's why I am not able to push my local branch towards the remote repository on my small server. I've installed Apache and Git 1.7.2.3. I am using Fundamental Authentication and also have enabled mod_cgi, mod_env and mod_alias. My apache config apply for the git stuff is situated at /etc/apache2/sites-available/git and it has concerning the following contents:

 <VirtualHost *:80>
         Servername git.mydomain.com
         DocumentRoot /var/git
         SetEnv GIT_PROJECT_ROOT /var/git/
         SetEnv GIT_HTTP_EXPORT_ALL
         ScriptAlias /git/ /usr/lib/git-core/git-http-backend/
         <Directory "/var/git">
            DAV On
            Options +Indexes +FollowSymLinks
            Deny from all
            AuthType Basic
            AuthName "git repository"
            AuthUserFile /var/git/.htpasswd
            AuthGroupFile /var/git/.htgroup
         </Directory>
         <Directory /var/git/allternative>
                 Allow from all
                 Order allow,deny
                 Require group allternative
         </Directory>
         <Directory "/usr/lib/git-core/git-receive-pack">
                 Allow from all
                 Order allow,deny
                 Require group allternative
         </Directory>
 </VirtualHost>

The diretories would be the following:

  • /var/git: This is actually the directory where my databases is going to be
  • /var/git/allternative: This is actually the directory in which the (bare) repository lies that I am presently trying to setup

Used to do exactly what I just read about this article (and many more saying comparable): http://progit.org/2010/03/04/smart-http.html

I get the mistake from Egit that remote Wise HTTP isn't enabled. What shall we be held missing?

Thanks ahead of time, Andreas

Responding to my very own question: I changed the ScriptAlias directive with this particular:

  ScriptAliasMatch \
    "(?x)^/(.*/(HEAD | \
      info/refs | \
        objects/(info/[^/]+ | \
          [0-9a-f]{2}/[0-9a-f]{38} | \
            pack/pack-[0-9a-f]{40}\.(pack|idx)) | \
              git-(upload|receive)-pack))$" \
               "/usr/lib/git-core/git-http-backend/$1"

As Well As added the next directive:

SetEnv REMOTE_USER=$REDIRECT_REMOTE_USER

It labored. I discovered individuals two configurations on http://www.espace.com.eg/blog/2010/11/10/migrating-from-subversion-to-git/ and I am not quite sure which among the two reduced the problem, however i assume it had been the SetEnv REMOTE_USER=$REDIRECT_REMOTE_USER directive.