2011-10-24T05:54:00+00:00 application[web.1]: Began Publish "/customers" for 69.136.182.141 at 2011-10-23 22:54:00 -0700

2011-10-24T05:54:00+00:00 application[web.1]:   Processing by Devise::RegistrationsController#create as HTML

2011-10-24T05:54:00+00:00 application[web.1]:   Parameters: Strained]", "password_confirmation"=>"[Strained]", "commit"=>"Register"

2011-10-24T05:54:00+00:00 application[web.1]: Made devise/mailer/confirmation_instructions.html.erb (.4ms)

2011-10-24T05:54:03+00:00 application[web.1]:

2011-10-24T05:54:03+00:00 application[web.1]: Sent mail to [not_telling]@gmail.com (3003ms)

2011-10-24T05:54:03+00:00 application[web.1]: Completed 500 Internal Server Error in 3137ms

2011-10-24T05:54:03+00:00 application[web.1]:

2011-10-24T05:54:03+00:00 application[web.1]: Errno::ECONNREFUSED (Connection declined - connect(2)):

2011-10-24T05:54:03+00:00 application[web.1]:

2011-10-24T05:54:03+00:00 heroku[router]: Publish swinglx.heroku.com/customers dyno=web.1 queue= wait=0ms service=3147ms status=500 bytes=728

2011-10-24T05:54:03+00:00 application[web.1]:

2011-10-24T05:54:03+00:00 application[web.1]:

2011-10-24T05:54:03+00:00 application[web.1]: cache: [Publish /customers] invalidate, pass

Any idea what's leading to the issue?

Does heroku run in production?

my production URL is SwingLX.com which has not registered yet using the DNS title server switch.

Heroku doesn't provide in whatever way of delivering email automatically - for example local sendmail or similar. Consequently you should utilize an exterior provider for example their SendGrid addon http://devcenter.heroku.com/articles/sendgrid that you simply would send email through.