I'm getting an unusual problem with apache and ssh, will be able to correlate towards the hg update command.

After performing

$ hg update

on the remote server from the changeset push in excess of one or two files. For 1 minute after, the apache server returns 403(on local files for example images), and 404(on exterior files for example jquery libraries).

Also, throughout the same time frame period basically try to push more changes towards the remote server, I recieve the response

remote: ssh: connect to host *hostname* port 22: No route to host

After about one or two minutes the problem disappears, and also the server returns to some working condition using the new changes effectively in position.

Once I execute hg update, the spend returns immediately with no response. Normally at these times the alterations are effectively in position.

The only real reckon that I've is the fact that mercurial is hanging like a background process and securing httpd and sshd procedures in some way?

I looked within the apache logs and there isn't any errors showing anything unusual is happening.

UPDATE

I discovered two errors during my apache error_log which i think may be related.

(104)Connection reset by peer: core_output_filter: writing data to the network
(32)Broken pipe: core_output_filter: writing data to the network

The mercurial problem disappeared after i restarted my apache server. However I must understand what triggered the problem to begin with.

The 2 log errors still persist too despite, turning EnableSendFile and EnableMMAP off within the httpd.conf

Thanks,

Erectile dysfunction

I believe this can be a recorded bug with mercurial. I am trying to puzzle out an answer for this too at this time. http://www.selenic.com/pipermail/mercurial-devel/2009-The month of january/010098.html http://mercurial.selenic.com/bts/issue1487 http://mercurial.selenic.com/bts/issue1787