I've been contacted to repair the performance of the Joomla site which was already setup.

I consider the debug output also it shows exactly the same queries two times, once for queries drenched and again for legacy queries drenched. My prediction is it is really running exactly the same queries two times alllow for just below 900 queries per page (hope I'm wrong)

The Legacy wordpress plugin is disabled, so Legacy mode is this is not on whatsoever. The website uses VirtueMart too (which BTW is not working correctly when the cache within the Global Config is switched on)

Besides the truth that I do not think it ought to be running 446 queries anyway (often even as much as 650 per page ), has anybody every experienced this problem, and where would I turn to fix this.


Answer the question below... It's running Artio JoomSef, together with the machine - SEF wordpress plugin


I have a similar Problem. However I also provide the issue having a fresh jommla / virtuemart installation. (I've attempted local with xampp and sample items).

Basically activate the legacy wordpress plugin, the numer of legacy queries is definitely 4.

ps: sorry for my bad british...

possibly this link can assist you to accelerate the queries. (however i aren't able to find the string within the shop_browse_queries.php)....


I discovered the solution... I have been battling with this particular for any very long time. This really is being triggered through the Virtuemart Product Snapshot wordpress plugin. Should you disable this wordpress plugin your legacy issues goes away.

I've approached virtuemart relating to this.