I attempted to obtain avatar at single (publish) page by these codes

  <?php
     echo get_avatar( $id_or_email, $size = '96' );
     ?>

  <?php echo get_avatar( $comment, 32 ); ?>

  <?php echo get_avatar( $id_or_email, $size, $default, $alt ); ?>

  <?php echo get_avatar( get_the_author_email(), '60' ); ?>

But no success, nothing get working. It always show default gravatar. Really author have avatar at gravatar. But it doesn't show.

Can anybody please let me know correct methods to display avatar at single publish page ?

Have you got avatars enabled at Admin/Configurations/Discussion?

Also check Using Gravatars « WordPress Codex for code good examples.