I've been attempting to install the most recent version of mod_wsgi (3.3) since hrs on my small Mac. I am on Snow Leopard and that i possess the versions of Apache (Apache/2.2.15) and Python 2.6.1 (r261:67515) that include the machine.

  1. I downloaded mod_wsgi-3.3.tar.gz from http://code.google.com/p/modwsgi/downloads/detail?name=mod_wsgi-3.3.tar.gz

  2. Removed the file and performed the next through terminal:

./configure make sudo make install

  1. I added LoadModule wsgi_module modules/mod_wsgi.to my httpd.conf.

  2. Restarted Apache by crippling and enabling Web Discussing in the user interface.

  3. localhost reduces until I take away the line I added httpd.conf :(

Help. Thanks ahead of time.

I personally use the homebrew installed version of mod_wsgi. That provides us a universal version of mod_wsgi that actually works using the vanilla apache.

➔  file `brew list mod_wsgi`
/usr/local/Cellar/mod_wsgi/3.2/libexec/mod_wsgi.so: Mach-O universal binary with 2 architectures
/usr/local/Cellar/mod_wsgi/3.2/libexec/mod_wsgi.so (for architecture x86_64):   Mach-O 64-bit bundle x86_64
/usr/local/Cellar/mod_wsgi/3.2/libexec/mod_wsgi.so (for architecture i386): Mach-O bundle i386

The issue you'd was the road to mod_wsgi.so. On OS X the right lines are

LoadModule wsgi_module        libexec/apache2/mod_wsgi.so